Custom fields into pagelayout

Oct 20, 2012 at 12:39 PM

Woaw, this is awesome! I have been working with the mundpublishing and it seems to do what it says. The only thing I cannot get to work, is adding custom fields into the pagelayout. The example in the documentation states it should work, ....  I tried to add a simple column to the page layout; a single line of text, called FeatureHeader. I add that column to the Mund Publishing Columns. I also added that column to the content type.... 

But when I create a page based on that content type and go into edit mode, the field is not showing....

Sorry if I ask the wrong questions, I am just getting into sharepoint, but any ideas? 

Coordinator
Nov 6, 2012 at 6:21 AM
Edited Nov 6, 2012 at 6:22 AM

Hi chefdog,

Try in this way:

1. Create the required column using any field type.

2. Add that column to the content type or in the pages library.

3. Edit the page layout and add the column.

e.g: <MundPublishing:PageEdit id="fld001" FieldName="YourColumnName" runat="server" />

4. Now create page using that page layout.

    * If you are not getting the field in the page while editing, you can check the field is working or not by using "Edit Properties" of the page.

Hope it would help. 

Nov 7, 2012 at 7:34 AM
Thanks for the support, i am going to try this and send feedback

Met vriendelijke groet, M.A. Van zuylen

Op 6 nov. 2012 om 07:21 heeft "kamalaagust" <notifications@codeplex.com> het volgende geschreven:

From: kamalaagust

Hi chefdog,

Yes, according to documentation it should work. Try in this way:

1. Create the required column using any field type.

2. Add that column to the content type or in the pages library.

3. Edit the page layout and add the column.

e.g: <MundPublishing:PageEdit id="fld001" FieldName="YourColumnName" runat="server" />

4. Now create page using that page layout.

* If you are not getting the field in the page while editing, you can check the field is working or not by using "Edit Properties" of the page.

Hope it would help.

Nov 7, 2012 at 8:12 AM

Tried it, made a powerpoint of the steps I took. But the field is not showing... If you want I can send the powerpoint file?

Coordinator
Nov 8, 2012 at 12:33 PM

For everyone's benefit could you please upload the PPT or its content here?

And then we would take it on from there...

Nov 9, 2012 at 9:25 AM

I really want to, but I cannot attach or upload anything?

Coordinator
Nov 9, 2012 at 3:17 PM
Edited Nov 9, 2012 at 4:45 PM

Chefdog, create an issue under issue tracker tab, there you can found an attachment option.

Nov 10, 2012 at 8:59 AM

Done! Thanks for the support so far! 

http://mundpublishingfeatur.codeplex.com/workitem/788

Coordinator
Nov 10, 2012 at 4:59 PM

Chefdog,

       Thank you for your PPT. When you are adding the column in the content type, it is not reflecting at the pages library's content type. This issue is arising only with SharePoint designer. If you try to add an existing column to a content type through the web UI its working fine. We suggest you to use web UI while adding columns to the content type. Actually we never did a test through SharePoint designer so thank you for bringing this issue out.

Nov 10, 2012 at 5:35 PM
OK, that is weird, but I try the solution. Thanks!!!!!!

On Sat, Nov 10, 2012 at 6:00 PM, kamalaagust <notifications@codeplex.com> wrote:

From: kamalaagust

Chefdog,

Thank you for your PPT. When you are adding the column in the content type, it is not reflecting at the pages library's content type. This issue is arising only with SharePoint designer. If you try to add an existing column to a content type through the web UI its working fine. We suggest you to use web UI while adding columns to the content type. Actually we never did a test through SharePoint designer so thank you for bringing this issue out.

Read the full discussion online.

To add a post to this discussion, reply to this email (mundpublishingfeatur@discussions.codeplex.com)

To start a new discussion for this project, email mundpublishingfeatur@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
-----------------------------
Marco van Zuylen
Marco@chefdog.com
Nov 11, 2012 at 3:47 PM
Done! It works! Thank you very much!

On Sat, Nov 10, 2012 at 6:35 PM, Marco van Zuylen <marco@chefdog.com> wrote:
OK, that is weird, but I try the solution. Thanks!!!!!!


On Sat, Nov 10, 2012 at 6:00 PM, kamalaagust <notifications@codeplex.com> wrote:

From: kamalaagust

Chefdog,

Thank you for your PPT. When you are adding the column in the content type, it is not reflecting at the pages library's content type. This issue is arising only with SharePoint designer. If you try to add an existing column to a content type through the web UI its working fine. We suggest you to use web UI while adding columns to the content type. Actually we never did a test through SharePoint designer so thank you for bringing this issue out.

Read the full discussion online.

To add a post to this discussion, reply to this email (mundpublishingfeatur@discussions.codeplex.com)

To start a new discussion for this project, email mundpublishingfeatur@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
-----------------------------
Marco van Zuylen
Marco@chefdog.com



--
-----------------------------
Marco van Zuylen
Marco@chefdog.com